Requirements and Installation

The latest stable version can be always found on PyPI.


Since doc2dash is an application, it has hard-coded dependency versions. I strongly discourage from installing it into your global site-packages because it will inevitably lead to conflicts. Either use pipsi or create a virtualenv by hand.

doc2dash runs on Python 2.7, and 3.4+, and PyPy. Both Linux and macOS are supported although certain features are only available on macOS.


For best performance when converting large pieces documentation, I strongly recommend using PyPy as the interpreter of choice.


To view the results, you will need a docset viewer, the most commonly known being for macOS.

Other alternatives have been developed in cooperation with’s developer Kapeli:

doc2dash is only tested against the original though.