Requirements and Installation

The latest stable version can be always found on PyPI.

Warning

I strongly discourage from installing doc2dash into your global site-packages because it will inevitably lead to conflicts. Either use pipx or create a virtualenv by hand.

As of version 3.0, doc2dash only runs on Python 3.7. If you need to run it on an older Python version, use one of the 2.x releases that are available on PyPI. All platforms that run Python are supported although certain features are only available on macOS.

Viewer

To view the results, you will need a docset viewer, the most commonly known being Dash.app for macOS.

Other alternatives have been developed in cooperation with Dash.app’s developer Kapeli:

doc2dash is only tested against the original Dash.app though.